This project has moved and is read-only. For the latest updates, please go here.

Action not visible in AS 2008 with perspectives

Aug 10, 2010 at 12:40 PM

We are using stored procedure ASSP.GetCustomDrillthroughMDX

....but when we migrate AS project to AS 2008 this one doesnt show up on Action list when we pick certain perspective and we made sure that all elements contained in the

GetCustomDrillthrughMDX are picked in the perspective tab page.

 

Does the ASSP.GetCustomDrillthroughMDX have a problem with perspectives on AS2008 ?

The same structure worked on AS2005.

 

 

 

 

Aug 10, 2010 at 2:48 PM

I think you need to download the latest source code from the source code tab and compile it yourself. We haven't done a release since we've fixed that problem.

If this is a problem to compile the source code yourself, please post back.

Aug 12, 2010 at 9:00 AM

Thanks for your reply.

We tried downloading the latest source code, compiling it and still have the problem.

Is there somewhere we can look ? SQL server 2008 version ? Trace ? Debug ?

 

 

Aug 12, 2010 at 3:47 PM
If you can help us repro against Adventure Works, then we can probably fix it. How did you setup the action?
Aug 13, 2010 at 11:47 AM
Edited Aug 13, 2010 at 11:52 AM

Dear furmanqq

We (mivar and I) have tried the following;

Recompiled the assembly (from ASSP_2008_1_3_Source) on the target machine: Window server 2008, 64-bit with 64-bit SQL 2008.

(The compilation of the assembly did give some problems since the refference (in the VS2008 project) to msmgdsrv.dll was invalid, though we fixed that, and the compilation looked succesfull)

Added Adventureworks  (originally an SSAS 2005 version, but upgraded to SSAS 2008) to target machine (Including the newly compiled assembly)

With the following Action:

Target type: Cells, Target object: All Cells.  Condition: none

Type: Rowset

Action expression:

ASSP.GetCustomDrillthroughMDX(
"membervalue ([$Date].[Date]),
NAME ([$Product].[Category]),
[Sales Orders].[Order Count]"
)
Invocation: Interactive
And added it to all perspectives.
The action is visible in the cube and it works, but it's not visible in any of the perspectives 
(including the "Sales summary" perspective, in which the measures and dimensions that the action refferences are contained). 
We would be very thankfull for any help on this.
Yours
Henrik Krogh

Aug 13, 2010 at 3:25 PM

You need to download the latest source code from the source code tab. Not from the Downloads tab.

I think we've fixed this bug in the source code. Not in the Downloads tab.

Aug 16, 2010 at 10:11 AM

Dear furmangg

After we have downloaded and compiled the latest source code from the source code tab, it now works.

Thanks a lot for speedy and efficient help.

 

Henrik Krogh

 

Dec 29, 2010 at 8:58 PM

We just released version 1.3.5 to the Downloads tab. That version contains the fix, so you no longer have to download the source code to get this fix.

Oct 12, 2011 at 3:23 PM

Hi

Once again I can't make this work.

I downloaded the 1.3.5 version and placed in project.

I didnt try on Adventureworks yet but when trying on live solution it just won't show actions. There is no multile choice and I tried even on server and from excel.

I brought action down to this to make testing simpler:

ASSP.GetCustomDrillthroughMDX(

"membervalue ([$Regnskabfact Dim].[Posting Date])"

 

)

Info: Cells, All Cells, Rowset.

I am on SQL Server 2008 - how can i trouble shoor or solve it ?

 

 

 

 

Oct 12, 2011 at 3:54 PM

It works on same server using Adventure Works but I have no clue why it doesnt work using other solution.

It doesnt look like a perspective issue as it doesnt work with any perspectives.

 

Oct 19, 2011 at 9:23 AM

It has something to do with the complexity of this particular cube. I brought it down from many measure groups to 1 measure group and then it turns up. I would like to debug where it has problems myself though - is that possible ?

Oct 20, 2011 at 8:48 PM

I think you just need to do this by a process of elimination, gradually adding more complexity back into your cube until it breaks.

If you create some other type of action at the same scope like a native drillthough or a url action do they work?

Oct 24, 2011 at 7:48 AM

Hi Darren

That was actually the method we started up with after we wrote the last and now found out that it is caused by a dimension with default member. We have a date dimension where its being defaulted to current date. i can take this logic along with some measure groups into separate cube since this area doesnt need to use the stored procedure and i think thats they way it will be.

Feb 23, 2012 at 8:43 AM
Edited Feb 23, 2012 at 9:04 AM

Hello....after downloading the 1.3.6 release of ASSP we are facing the same kind of issue with SQL SERVER 2008 R2.

No action visible in perspective  when using this kind of code :

"SELECT "  +  ASSP.FindCurrentTuple() + " ON 0 FROM [cube]"

Setting the action directly in the cube make the action to be visible....

I'm wondering is this a issue with ASSP or whit SQLSERVER2008R2....

 

Regards

Feb 27, 2012 at 4:17 PM
Edited Feb 28, 2012 at 8:26 AM

Just to give my feedback we have resolved this by a modification of the FindCurrentTuple() method (in Bold the modification to make it work) :

public static string FindCurrentTuple()
        {
            string output = "(";
            Boolean addcomma = false;

            foreach (Dimension d in Context.Cubes[AMOHelpers.GetCurrentCubeName()].Dimensions)
            {
                foreach (Hierarchy h in d.AttributeHierarchies)
                {
                    if (d.DimensionType == DimensionTypeEnum.Measure || h.CurrentMember.UniqueName != h.DefaultMember)
                    {
                        if (addcomma == false)
                            addcomma = true;
                        else
                            output += ",";

                        output += h.CurrentMember.UniqueName;
                    }
                }
            }
            output += ")";

            return output;
        }

 

 

Feb 27, 2012 at 7:55 PM

Thanks for the feedback fpatou. That fix makes sense as the built-in methods for getting the current cube name always return the base cube not the perspective name and this would probably create an invalid tuple for the perspective in this case.

Feb 27, 2012 at 8:42 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Feb 28, 2012 at 8:30 AM
dgosbell wrote:

Thanks for the feedback fpatou. That fix makes sense as the built-in methods for getting the current cube name always return the base cube not the perspective name and this would probably create an invalid tuple for the perspective in this case.

Hello....can you please explain why this could be wrong?

As far as i know the Perspective is not a secured object in SSAS, and the perspective is mono cube based...then the result will always be "consistent" as the context of a perspective is always valide for his underlying cube...

Feb 28, 2012 at 9:01 AM

It's not wrong - your fix is perfectly correct and we are planning to incorporate it into the project.

Feb 28, 2012 at 9:14 AM

I guess this kind of fix has to be propagate in some other methods of the FindCurrentMembers cs....;-)

Feb 28, 2012 at 9:47 AM

Yes, I think so. The FindCurrentMember.cs was one of the very first modules that was written and it obviously was not revisited when we uncovered the perspective issue.