This project has moved and is read-only. For the latest updates, please go here.

AS2014 version

Topics: Developer Forum
Sep 2, 2014 at 11:37 PM
Firstly thanks for your efforts with this project! Just wondering if there is an AS2014 version in the works and when this might be available?
Sep 9, 2014 at 11:49 AM
I just haven't had time to get to this yet. I will update this thread when I do. You will have to compile yourself for the time being. No ETA at the moment.
Dec 3, 2014 at 9:32 PM
Just wondering if there were any updates regarding an ETA for a 2014 version.
Dec 9, 2014 at 7:14 PM
FYI, I was able to compile this in VS 2013 and deploy the assembly to SQL 2014. I can verify that discoverXMLMetaData and DiscoverXMLMetaDataFull calls function properly.
Jan 5, 2015 at 7:04 AM
Sorry for the long wait, but I just released a new 1.3.7 version which includes an Analysis Services 2014 compatible version. Let me know if you have any troubles with it.
Marked as answer by furmangg on 1/4/2015 at 11:05 PM
Jan 9, 2015 at 3:57 PM
I've had a chance to do some testing this week and it is running perfectly for DiscoverXMLMetaData and DiscoverXMLMetaDataFull calls. I may be leveraging some additional functionality for a project that is in progress and will test against 2014 as well and report results here.
Jan 9, 2015 at 10:45 PM
All good based on very limited testing.
Jan 29, 2015 at 1:10 PM
Edited Jan 29, 2015 at 1:11 PM
I am trying to run call assp.DiscoverXmlMetadata on AS2014 and am receiving an error. It seems that assp.DiscoverXmlMetadata is trying to use Microsoft.AnalysisServices.Xmla, Version= on my AS2014 box. Should assp.DiscoverXmlMetadata be using verion or do i need to install the AS2008 version of Microsoft.AnalysisServices.Xmla?

Jan 29, 2015 at 9:09 PM
What file name did you download from the Releases page?

I downloaded "ASSP 2014" and took a look at the DLL references and I see it references version 12:
Microsoft.AnalysisServices.Xmla, Version=, Culture=neutral, PublicKeyToken=89845dcd8080cc91

Is there a chance you downloaded and installed the wrong file?
Jan 29, 2015 at 9:56 PM
Used the same file. If I want to delete the existing and start again - what are the steps to remove an existing ASSP assembly?
Jan 30, 2015 at 10:51 AM
To remove the existing ASSP assembly, connect Object Explorer in SSMS to your SSAS server, then expand the Assemblies folder and right click on ASSP and delete it.

(I assume you added ASSP at the server level. You could potentially have added it from the Assemblies folder within a database so you might double check it's not there and overriding the server level assembly.)
Jan 30, 2015 at 12:56 PM
I deleted the current ASSP, downloaded ASSP 2014, installed new ASSP to the AS as described in the installation guide - and I still get the same error can't find file Microsoft.AnalysisServices.Xmla, Version=

Any other suggestions?

Jan 31, 2015 at 11:03 AM
I downloaded ASSP 2014 and installed it on the AS2014 server and ran this, which worked fine.
CALL ASSP.discoverXmlMetaData("\Database\Cubes\Cube\Dimensions\Dimension");

In the top of Object Explorer in SSMS connected to SSAS I double checked it was AS2014. My exact version was 12.0.2381. Can you check what version number you have?

I even installed Sysinternals Process Explorer, opened up the details on msmdsrv.exe and verified the Microsoft.AnalysisServices.Xmla assembly was the 12.0 version.
Feb 2, 2015 at 12:44 PM
My SSAS version is 12.0.2000.8. I also have the 12.0 version or Microsoft.AnalysisServices.Xmla installed. So we seem to have all of the correct components installed.

The AS database that we are running this against was created in AS2008R2 - would that have any impact on this?
Feb 2, 2015 at 12:47 PM
I just discovered the problem - The individual database had an associated ASSP assembly from the 2008R2 version - so it was taking precedence over the server-wide ASSP assembly. I deleted that version, and now everything is working!!

thanks for your help!