This project has moved. For the latest updates, please go here.

Exception has been thrown by the target of an invocation

Dec 9, 2009 at 6:27 AM

The project runs fine against a Sql 2005 instance, but when I run the reports against a Sql 2008 R2 instance, the 'Discover Cube Status' report fails with 'Exception has been thrown by the target of an invocation.  Syntax error: Missing operand before '<' operator.

I tried some quick debugging, and this call in the dsdatabases dataset: CALL ASSP.DiscoverXmlMetadataFull("\Databases\Database","<ObjectExpansion>ExpandObject</ObjectExpansion>") fails, but if you remove the second param, the '("\Databases\Database")', it excecutes fine.

Again, it's only against Nov CTP R2 SSAS.

Any ideas?


Dec 22, 2009 at 5:37 AM

We have not done any testing against R2, but I suspect that this could be related to a signature change with the DiscoverXmlMetatdata() function a while ago and I don't think the 2008 version of the report was updated. We have checked in a change that is not yet part of the latest release, if you download the latest changeset form the 'Source Code' tab you could try this version and see if it works.

Dec 23, 2009 at 7:33 PM
Edited Dec 23, 2009 at 7:36 PM

I get same failure on a SQL Server 2008 installation (64 bit, SP1).  I tried this with the release and the most recent version of the source code.

Dec 23, 2009 at 8:36 PM

Is this with the report from the releases tab, or the one from the latest changeset? There was an error in the last release, but the one in the latest changeset should work in 2008 (and it should work in R2, I just have not tested it there yet)

Jan 8, 2010 at 11:17 PM

I get the same error. I got my reports from: ASSP 2008 1.3.1 source

In the Downloads Tab. Is this the right one?

By the way, this is all great stuff!! Thanks!!

Jan 9, 2010 at 2:24 PM
Edited Jan 9, 2010 at 2:24 PM

Nevermind I found them, not readily found. Fixed! Anyway, awesome stuff, thanks again!!

Jan 10, 2010 at 9:37 PM

yeah, the source tab is not the easiest thing to use. It's probably only experienced codeplex users that ever look there. Thanks for letting me know that this works for you. I will have to organize another release to get this fix into a proper release.