This project has moved. For the latest updates, please go here.

Error: Query execution failed for dataset 'DimensionHealthCheckResults'.

Topics: Developer Forum, User Forum
Jan 13, 2010 at 10:00 PM

I am running the Dimension health Check Report and I get this error:

Query execution failed for dataset 'DimensionHealthCheckResults'.

    • Execution of the managed stored procedure ListDimensionErrors failed with the following error: Exception has been thrown by the target of an invocation.Could not open connection to data source DBWarehouse. Because the password for a SQL security connection cannot be retreived from SSAS, they are not supported. Register this assembly with impersonation settings which have access to connect to the data source using Integrated Security. Exception was: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

I tried setting the Assembly impersonation to every available setting and no go.

This points to our warehouse relational DB, and we use Windows Integrated Security, so not sure if that has anything to so with it.

I'd rather not have to change any major security settings to make this work.


Any ideas?


Jan 14, 2010 at 5:18 AM

I'm not sure if the wording of this error message is entirely correct, but basically it is coming out of an exception that is thrown when trying to connect to the data source.

How are the services deployed in your environment - Is SSRS on a different machine to SSAS or the DB engine? If so this is probably an authentication issue caused by the fact that NTLM credentials cannot be passed from server to server. In a multi machine environment you would need to configure kerberos authentication (there are a couple of KB articles on the MS site for setting up Kerberos with SSAS) or possibly deploy the assembly with the option to impersonate a specific windows account (although I realise that you mentioned that you have tried all of the impersonation options).

Jan 14, 2010 at 2:18 PM


I got SSRS and SSAS on the same machine, but the ralational bits are on another machine.

And yes I did try impersonating a specific user to no avail.

We do have Kerberos set up also because we access our user reports through Sharepoint. Perhaps it's a matter of applying some other settings on Kerberos to allow this (but that's probably out of the question for me.)

Anyway, I wonder how the other ASSP reports work and don't issue security errors.


Jan 14, 2010 at 3:54 PM

OK, we had a service user that I could use to impersonate and now it works. Nice!


Jan 14, 2010 at 11:14 PM
ericblair wrote:

Anyway, I wonder how the other ASSP reports work and don't issue security errors.

Most of the other functions in ASSP only access SSAS data. I think that the dimension health check may be the only function that connects back to the source data. So in your case this would be the only function that would require kerberos and an account with impersonation rights.