This project has moved and is read-only. For the latest updates, please go here.

Error while executing ClearAllCaches

Topics: Developer Forum
Mar 25, 2011 at 2:36 AM


I downloaded latest version 1.3.5 version of ASSP and installed in on SQL Server 2008R2 64bit as recommended:

Impersonation info: Default

Permission set: Unrestricted.

When I am executing "CALL ASSP.ClearAllCaches()", I am getting error message:

Executing the query ...
Execution of the managed stored procedure ClearAllCaches failed with the following error: Exception has been thrown by the target of an invocation.NtSetSystemInformation(SYSTEMCACHEINFORMATION) error:
Not all privileges or groups referenced are assigned to the caller.
Execution complete

What can I do to make this error go away? What permissions could be missing?


Mar 25, 2011 at 3:16 PM

Try temporarily changing the assembly Impersonation to use the service account. See if that fixes the problem. If it does, then there's some difference between your account (did you run as administrator?) and the service account.

Mar 25, 2011 at 3:23 PM
Edited Mar 25, 2011 at 3:52 PM

I tried different impersonation options:

- Use the credentials of the current user  - same error

- use the service account - same error

- use a specific Windows user name or password - that works. Note - I used the same account that I am logged in and I am local administrator on machine. Note - everything was run from one single box.

So it works with specific windows user name.

Mar 25, 2011 at 8:24 PM

Interesting. What user account did you use for the specific user name? If you changed it to the credentials of the current user, logged into the computer as that specific user name, ran SSMS as administrator, would it work? I'm trying to figure out if it's the account or if it's not running SSMS as administrator.

Mar 25, 2011 at 8:30 PM


I am logged in to console of the Windows 2008 R2 server using domain\VMatelis account. When I specified user, I specified the same account, so again domain\VMatelis.Are there any logs/thinks I can help you with to figure this issue out? I am using it as is with no problems, just you probably need to figure this out for others.

By the way, this ClearAllCaches function is extremely useful for MDX testing. Thank you very much for it!

Mar 26, 2011 at 1:56 AM

Additional info:

I just reset Permission set to unrestricted and confirmed that I am getting original error message. Then I closed SSMS and started it again but this time with "Run as Administrator" option. Then calling function works without problems.