This project has moved and is read-only. For the latest updates, please go here.

Writing assp procedure to sql table.

Topics: Developer Forum, Project Management Forum, User Forum
Dec 18, 2011 at 3:46 AM
Edited Dec 18, 2011 at 3:47 AM

I appear to be having the same problem as the person in this thread

I have the newest version installed. The procedure works fine when I run it against analysis services without using openrowset.

When I try to run the following query I get the same error message as in the thread I linked.

select *  from openrowset('MSOLAP','Datasource=server1molap;initial catalog=[Mart_Test];','CALL ASSP.discoverXmlMetaDataFull("\Database|Name\Cubes\Cube\MeasureGroups\MeasureGroup\Partitions\Partition");')

So next I created a linked server and try running the following.

select * from openquery(server1molap,'CALL ASSP.discoverXmlMetaData("\Database|Name\Cubes\Cube\MeasureGroups\MeasureGroup\Partitions\Partition");')

But I get: Exception has been thrown by the target of an invocation.Index was outside the bounds of the array error.


Any help is appreciated

Dec 18, 2011 at 11:20 AM

Hi there, I think I found this issue. I've checked in a change to the source and just need to coordinate with the other guys on the team before doing another release.

Dec 19, 2011 at 7:08 PM

Thanks for looking into this. Do you have an estimate when the new release will be available?

Dec 21, 2011 at 5:02 PM

The new version is working with openquery and a linked server.