This project has moved and is read-only. For the latest updates, please go here.

Error using ASSP on sql server 2012, visual studio 2010

Topics: Developer Forum
Nov 12, 2012 at 11:36 AM

Vi get following error when trying to attach DLL to analysis services project:

"xx is not a valid .Net assembly and can not be added to Analysis Services Project".

We have been using the assembly with success before upgrading to new sql server 2012 - as part of upgrade old sql server and visual studio were uninstalled - could that be the reason ?

Nov 12, 2012 at 2:18 PM

it doesn't sound like the same error as you get when you don't unblock the DLL before adding the assembly to SSAS2012. But you might try that:

Nov 12, 2012 at 11:16 PM

Are you using the latest version? Have you downloaded the 2012 build of the dll?

Nov 12, 2012 at 11:32 PM

Tx for a brilliant project and speedy replies both of you. Both input worked. However I couldn't seem to be able to register DLL inside visual studio 2010 project anymore like I did before. But when registrering (the right one!) on AS server it worked.