This project has moved and is read-only. For the latest updates, please go here.

SSAS 2012 using ASSP : "No connection could be made because the target machine actively refused it."

Topics: Developer Forum
Apr 29, 2013 at 8:51 AM
Hello...on SSAS 2012 i'm trying to use this command

CALL ASSP.DiscoverXmlMetadataFull("\Databases\Database", "State<>'Processed'" ,"<ObjectExpansion>ExpandObject</ObjectExpansion>")

and get error :

"No connection could be made because the target machine actively refused it."

Any ideas to solve it ?

Apr 29, 2013 at 10:42 AM
Usually this "actively refused" error means that the SSAS Service or SQL Browser service is not running. (see

Can you run other ASSP functions like CALL ASSP.DMV("SELECT * FROM $SYSTEM.DISCOVER_SESSIONS") ?

Is your SSAS instance running under a domain account or one of the built-in accounts like local system or network service.

What permissions and impersonation options did you choose when you installed ASSP?
Apr 29, 2013 at 11:05 AM
Edited Apr 29, 2013 at 11:05 AM
CALL ASSP.DMV("SELECT * FROM $SYSTEM.DISCOVER_SESSIONS") : This doesn't work ! :-( same error message

SSAS instance run under domain account and i gave ImpersonateServiceAccount and Unrestricted to the permission set...

SQL browser is running

thanks for your help ...
Apr 29, 2013 at 3:33 PM
I ran into a strange installation of SSAS recently where it was a named instance but the port had been changed to the default port and SQL browser had been stopped. So when one of those sprocs mentioned above ran, AdomdServer.Context.CurrentServerID was saying the instance name was SERVERNAME\SSAS and since SQL Browser wasn't running, it failed.

I know you said SQL Browser was running. But the point is that you may be connecting to the instance with a different server and instance name than SSAS internally thinks it is... then the sprocs will try to connect to SSAS under the server and instance name it knows.

If you connect Object Explorer in Management Studio to SSAS, then right click on the server node and choose Properties, does SSMS show you the server name? Can you connect using the name shown rather than how you're connecting now? (That's a new feature, if I recall. I can't recall when they added the new tab in the properties window to show you instance info.)
Apr 29, 2013 at 4:39 PM
Ok i found the deals with the msmdredir.ini.

refering this :

after removing the IPV6 entry from int this section it works :
before :
After :
Thank you for your help.